Checksum Verifier

Description

Checksum Verifier berechnet die MD5 Prüfsummen für alle existierenen WordPress Core Dateien und gleicht diese mit den offiziellen Prüfsummen ab. Dadurch erkennt es, wenn unbekannte Änderungen an Ihrem WordPress Core System vorgenommen wurden (zum Beispiel SoakSoak Malware) und kann darauf reagieren.

Checksum Verifier überprüft täglich die MD5 Prüfsummen. Falls eine unerwartete Änderungen an den Core Dateien festgestellt wurde, sendet das Plugin eine E-Mail mit einer Liste der betroffenen Dateien an den Administrator der Seite (oder Super-Admin bei WordPress Multisite). Die erste Prüfung wird bei der Aktivierung des Plugins durchgeführt. Reguläre Core Updates werden natürlich keinen Alarm auslösen. Das Plugin wird dich nur benachrichtigen, falls Core Dateien kompromittiert wurden und Ihre Seite möglicherweise gehackt wurde.

Checksum Verifier arbeitet als „stiller“ Hintergrunddienst und benachrichtigt Sie nur, falls unerwartete Änderungen an Dateien festgestellt wurden, die möglicherweise eine Gefahr für die Core-Installation darstellen.

Verbesserte Sicherheit für WordPress.

Verwendbare Hooks

  • checksum_verifier_ignore_files
    Änderung oder Erweiterung eines array von Dateipfaden relativ zu Ihrem WordPress Installationspfad, welche von der Verifikation ausgeschlossen werden.
    Standard ist array('wp-config-sample.php', 'wp-includes/version.php', 'readme.html', 'readme-ja.html', 'liesmich.html', 'olvasdel.html', 'procitajme.html').

Support

Mitwirken

  • Die aktive Entwicklung dieses Plugins findet auf GitHub statt.
  • Pull-Anfragen für dokumentierte Fehler sind sehr willkommen.
  • Wenn Sie denken, dass Sie einen Fehler gefunden haben (z.B. falls unerwartetes Verhalten auftritt), hinterlassen Sie bitte zuerst einen Beitrag im Support-Forum.
  • Wenn Sie uns helfen möchten, das Plugin zu übersetzen, können Sie dies auf WordPress Translate tun.

Danksagungen

Installation

  • Sollten Sie nicht wissen, wie ein Plugin für WordPress installiert werden kann, bieten wir hier eine Anleitung an.

Systemanforderungen

  • WordPress 3.8 und höher
  • PHP 5.2.4 und höher

Reviews

17. Juli 2018
this plugin found a virus that was overlooked by both quttera and clamav. the virus was doing bitcoin mining on our server, consuming much of our resources. thank you for providing such a useful plugin.
Read all 4 reviews

Contributors & Developers

“Checksum Verifier” is open source software. The following people have contributed to this plugin.

Contributors

“Checksum Verifier” has been translated into 2 locales. Thank you to the translators for their contributions.

Translate “Checksum Verifier” into your language.

Interested in development?

Browse the code, check out the SVN repository, or subscribe to the development log by RSS.

Changelog

0.0.3

  • Remove lang folder in favor of the usage of translate.wordpress.org

0.0.2

  • wp-content/ Verzeichnis von Prüfung ausgeschlossen
  • Lokalisierte readme.html Dateien von Prüfung ausgeschlossen
  • Kleinere Code-Verbesserungen
  • Explizites Setzen der maximalen Ausführzeit entfernt

0.0.1

  • Checksum Verifier nimmt seinen Betrieb auf